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microcontroller then it changes the sampling frequency
accordingly: a higher sampling rate for single channel and
half of that for dual channel [8].

Abstract - In today’s world android Smartphone plays a
important role to users. A Smartphone based handheld
oscilloscope has been developed in this work. The oscilloscopes
are playing a vital role in electronics laboratory, industries etc.
The oscilloscopes cost in the field is very expensive, less power
efficient and have small low resolution displays. This paper
presents the design and functions of a hardware device using
IOIO which captures input analog signal and the signal is
interfaced with the Bluetooth module which is for transmitting
captured signal information to android device. The input
parameter (analog signal) is converted to digital signal (into
byte) by using the inbuilt analog to digital converter of the IOIO
board. Through an android device, an android application to
receive the data transmitted from hardware device is designed
and it is plotted as a waveform. An android device used to design
a low cost and effective measuring device. A waveform is
displayed in an android OS based Smartphone, according to the
user configuration. The sampling value and the sampling rate is
set by the user, currently analog input pins are sampled 1000
times a second. The android application includes the CRO to
analyse the waveform, multi-meter to measure the voltage and
current of the device and the logic analyser shows the digital
waveform of the system.

II. LITERATURE SURVEY
A. Wireless Oscilloscope
The wireless oscilloscope displays the waveform in the
laptop as a hardware device and the connectivity is done by
Zigbee module and the software used is the MATLAB in
the PC. It captures the voltage signals, transmitting the
signal information to the system for visualizing the
waveform. With the help of Zigbee module the transmission
between the laptop is successfully done by the system. The
display configuration given by the hardware device is set by
the user and is used by the hardware device to choose the
sample rate and the sample values [9].
B. Portable Oscilloscope
The portable oscilloscope is contains a microcontroller
for a data rate acquisition and display the waveform in a
graphical liquid crystal display(GLCD).the oscilloscope
displays a waveform in a real time by reading a finite
number of samples and storing them into its internal RAM.
Once the memory is full in the microcontroller it stops
sampling. It contains a four major units are power supply
unit, analog signal conditioning unit, analog to digital
converter unit, processing and display unit. So in this
portable oscilloscope the memory causes a issues in the
system [10].
C. Issues with CRO

Index Terms: Android application, Bluetooth device, IOIO
OTG Development board, Multi-meter, Logic analyzer,
Smartphone.

I. INTRODUCTION
An oscilloscope called an oscillo-graph, it is a type of
electronic test instrument and constantly varying the signal
voltage in two dimensional port. It is used to observe the
changes in the electrical signal and analyses the waveform
such as amplitude, time interval, and frequency response of
the system. Portable oscilloscope is a new trend in the
market. It is very much cost, less efficient and low
resolutions display [1].
The Idea of the android based oscilloscope is to design
and implement a light weight, compatible and easily
available oscilloscope which consists of a hardware device
and software application [2]. The hardware device requires
a small circuitry to manage input signal and to provide the
signal to Bluetooth device. The Bluetooth device is
interfaced with the IOIO board to exchange the data
wirelessly with the other Bluetooth devices. In the software
application, it contains the android framework provides the
Bluetooth functionality through the android Bluetooth
Application Program Interface (API) [7]. The developed
software application will work in a range of 30 meters
between the IOIO board Bluetooth device and Bluetooth of
android Smartphone. The Bluetooth contains a dual channel
operation with which the user can choose a mode from the
application, which in turn sends a signal to the PIC

CRO is a function to measure the voltage, waveform
display, parameter analyses and for testing the signals. It is
mainly used for experimental results in educational
laboratory and industries application. The disadvantage of
the device is very much costly and we cannot able to carry
everywhere. The student does not have that much money to
buy it. To overcome the issues, CRO can be developed in
an android application through Java program. It is more
advantage to the user, because it is less cost, easy
availability, and eco-friendly [3].
D.HCI Mode
Host Controller interface is the On-board stack is
eliminated and the module is placed in a state that executes
the Bluetooth module bandwidth. The Bluetooth stack is not
properly designed in the Bluetooth module. So compulsory
it is interface with the basic PIC controller. The
disadvantage of the HCI mode is not efficient with the highend microcontroller with the complex firmware and
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hardware designed module. In the HCI mode it will perform
V.SYSTEM OVERVIEW
in the less baseband layer protocol [5].
A. Hardware Design
1. IOIO Board
The IOIO is a board that provides a host machine the
capability of interfacing with external hardware over a
variety of commonly used protocols. The original IOIO
board has been specifically designed to with the android
device. The newer IOIO-OTG (“on the go”) boards work
with both Android device and PC’s. The IOIO board can be
connected to its host over USB or Bluetooth and provides a
high level Java API on the host side for using its I/O
functions as if they were an integral part of the client. The
limitation of operating frequency range is up to 1 GHz. the
IOIO board with its I/O pins input voltage and ground pin.
Also, using the IOIO-OTG android mobile or tab can
directly communicate without extra modification in
hardware or their software. The IOIO board uses multiple
protocols to communicate with a control device. There is
the hardware protocol layer, i.e. using the Bluetooth device
or a USB connection. Above that, there will be framing for
that protocol-over Bluetooth it uses a UART emulated
connection. Over USB it can use various android defined
protocols. Above that is the IOIO application Protocol
which allows an application running on the control device
to access the pins and commands of the IOIO
 Number of input channels: 2

E. Alternative Approach
A more reliable HC-05 is selected because it contains
many AT commands and can act as both master and slave
process. It can build a connection to other modules for a
wireless serial bridge. It gives a throughput 250kbps in a
slave mode.
III. RESEARCH DESIGN
The multipurpose handheld scope device has been
implemented. Following are the research objective of
multipurpose handheld scope system,
1. To develop multipurpose handheld device operator on
device like mobile or Tab.
2. To design compatible device with high frequency.
3. To develop a system to measure the signals and display it
wirelessly on an Android Operating system based Phone.
4. To make the oscilloscope compact and easy.
5.To implement a low – cost and effective Measurable
Device The Inputs given will be processed by an embedded
system and will be transmitted via a wireless
communication protocol (in our case Bluetooth Module).
A java based application will develop on the Android OS
platform which will accept this incoming data and visualize
the same. We will be developing a system which will work
two signals at a time.



Bandwidth: 2.5 kHz (dual channel mode) and
5kHz (single channel mode)



Input voltage range: -5 to +5 V with 1:1 probe



Sampling frequency: 10 kHz (dual channel mode)
and 20 kHz (single channel mode)

IV. HANDHELD OSCILLOSCOPE

The proposed block diagram is shown in fig 1 .It consists
of IOIO board, Bluetooth dongle and an android device.
The input signal is taken from the signal generator and
transfers the input to the IOIO board. Through the sampling
process it samples the analog signal and provides the signal
to the device. The android device receives the signal from
the board with the help of Bluetooth module to display the
waveform. In the android device developed an android
application in Smartphone to display the waveform.

2. Bluetooth Module
Bluetooth Data Rate Restrictions From research carried
out earlier it was found that data rates upon 2 Mbps are not
attainable with the existing software stacks designed on the
module's PIC controller. Therefore, the approach
recommended to fully utilize the bandwidth accessible by
Bluetooth, was to use the module in Host. Bluetooth
Embedded Controller Interface (HCI) mode, the on-board
stack is eliminated and the module is placed in a state that
executes the Bluetooth module bandwidth. Therefore, the
Bluetooth stack is not properly on the Bluetooth designed
module, so it is compulsory to be designed on the
interfacing basic PIC processor. So the module is designed
for radio broadcasting, executing the lower level MAC
operations, while the application stack runs on the basic PIC
processor. The advantage of HCI mode is that it permits to
achieve maximum throughput and also to execute custom
profiles on the Bluetooth module.
3. Android application
Android Smartphone The term “Android” has its origin
in the Greek word andr-, meaning “man or male” and the
suffix - aides, used to mean “alike or of the species”. This

Fig.1 Block Diagram of the handheld Oscilloscope
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together means as much as “being human”. Android is a
・Mac OS X 10.5.8 or later (x86 only)
software stack for mobile devices which means a reference
・Linux (tested on Ubuntu Linux, Lucid Lynx)
to a set of system programs or a set of application programs
・GNU C Library (glibc) 2.7 or later is required.
that form a complete system. This software platform
・On Ubuntu Linux, version 8.04 or later is
provides a foundation for applications just like a real
required.
working platform. The Android device used for testing a
・64-bit distributions must be capable of running
Samsung Galaxy Y (GT-S5360) Smartphone with Android
32- bit applications.
version 2.3.5 Gingerbread OS, an 832 MHz processor and
For information about how to add support for 32-bit
RAM of 290 MB. The Smartphone of a 3.0" QVGA
applications, see the Ubuntu Linux installation notes.
240x320 LCD screen with Bluetooth v3.0 + HS (High
Step2: Installing JAVA development kit (JDK)
Speed). It is one of the low cost Android Smartphone
available in the market to-date.
Get the latest Java SE version on the Java: Java SE
Using the Bluetooth APIs, an Android application can
download page
perform the following:

Scan for other Bluetooth devices

Query the local Bluetooth adapter for paired
Bluetooth devices

Establish RFCOMM channels

Connect to other devices through service
discovery

Transfer data to and from other devices

Manage multiple connections
Fig.3 Download JDK

Click on the JDK,accept the license agreement and
downloaded the right JAVA development kit version for
your Operating System
Note: If you are using a 64 bit os,you must downloaded the
64 bit version.

Fig.2: Flowchart to create an android app

B. Software Implementation
Install and configure the software needed to start
developing IOIO applications for Android! The aim of this
is to regroup all the needed information into a simple and
convenient tutorial, to quickly get you develop your first
IOIO
for
android
application.
Note: This tutorial involves a lot of downloads and
installations so make sure you have some time ahead of
you.

Fig.4 Java Installation

Follow the installation wizard's steps and install all of the
components and you don't have to register.
Step 3: Installing Eclipse IDE
Go to the Eclipse Download Page While any of those 3 is
recommended to develop Android Applications, just take
the Classic version if you're an IOIO beginner.
 Eclipse IDE for Java Developers
 Eclipse Classic
 Eclipse IDE for Java EE Developers
Download Eclipse for your OS. Eclipse Classic is a
standalone program; you don't have to install it. Just put the
Eclipse folder wherever you want on your computer, and
the "Eclipse" executable is the application.

Step 1: System Requirements
Source: http://developer.android.com/sdk/requirements.htm
l
Supported operating systems
・Windows XP (32-bit), Vista (32- or 64-bit),
Windows7.
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Step 4: Installing the Android SDK
 Click New....
 The Create New AVD dialog appears.
Source:http://developer.android/sdk/installing.
 Type the name of the AVD, such as "my_avd".
Go to the SDK download page and download the installer
 Choose a target. The target is the platform
for
your
OS.
 Click Create AVD.
Run
the
installer
and
follow
the
steps.
Troubleshoot: If the installer cannot find your Java SDK
and you have the JAVA_HOME variable error, follow these
steps.
When the installation finishes, the installer will ask you to
run
the
SDK
manager.
Don't, we will go through this step later.
Step 5: Run Eclipse IDE
This is the easiest step! Run the “eclipse” application and
create a shortcut if you want. Upon first launch, Eclipse will
ask you to create a workspace.

Fig.7 Android Virtual device to select the target and API
level

Step 9: Compile Your First IOIO Project! Import the IOIO
libraries

Fig.5 Eclipse





Step 6: Install the Android Development Tools (Adt) Plug-
in

Source: http://developer.android.com/sdk/eclipse.

Start Eclipse, then select Help > Install New Software....
In the "Work With:" area, click Add, in the top-right corner.
In the Add Repository dialog that appears, enter "ADT
Plug-in"

In eclipse, file>Import and select the projects into
workspace.
Click next
In “select root Directory” browse and unzipped IOIOLib.

Step 7: Install Android Packages
In eclipse, Window>Android SDK Manager. Then install
the IOIO library and API versions

Fig.8 IOIO project

VI. RESULTS
The operation of the device was tested by providing test
signals from the signal generator and to interface the IOIO
board with the Bluetooth module and created an android
application. Figure 9 and 10 shows a screen shot of the
application displaying the LED On when the IOIO is
Interface with the Bluetooth device and LED off when it is
unpaired condition. Figure 11 shows the measuring voltage
of potentiometer.

Fig.6 Android SDK Manager to select the version of API

Step 8: Create an Android Emulator




Source: http://developer/android/resources/helloworld.html.
In Eclipse, select Window > AVD Manager.
Select Virtual Devices in the left panel.
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